Re: UML fails to locate address space

From: Tom Spink
Date: Tue May 20 2008 - 14:01:17 EST

2008/5/20 Jeff Dike <jdike@xxxxxxxxxxx>:
> On Tue, May 20, 2008 at 05:43:17PM +0100, Tom Spink wrote:
>> I suspected this type of foul-play, and tried altering bottom to 1,
>> but this didn't work. So, I took out the page_ok test, and it
>> continued booting. So I went back, put the test back in and
>> incremented bottom until I got to 16. It worked at 16. :-)
> Heh, I guess they were also worried about up to 64K offsets off a NULL
> pointer too.


>> Is this something that can be fixed, or would a config option be
>> appropriate?
> This was done in order to remove config options. It might be
> reasonable to effectively do what you did, and search for the lowest
> address at which mmap works and start from there.

Cool, and nice work BTW. I just for-looped up the way, from 0.

>> I am willing to blame Ubuntu, but unfortunately, I can't find an
>> online resource of their patches.
> lists a bunch of git repos.
> Tell me which one applies to you and I'll take a look.

I'm a hardy. I bet it's 893f802872c3.;a=commitdiff;h=893f802872c3e3c6e4bb40c3be4845784b81b934

> Jeff

Tom Spink
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at