Re: [PATCH 18/57] iTCO: unlocked_ioctl, coding style and cleanup

From: Rusty Russell
Date: Wed May 21 2008 - 00:59:24 EST


On Wednesday 21 May 2008 14:36:54 Andrew Morton wrote:
> On Wed, 21 May 2008 14:26:15 +1000 Rusty Russell <rusty@xxxxxxxxxxxxxxx>
wrote:
> > > decent-sized smashup during the merge window. There are lessons
> > > here...
> >
> > I've been pulling out s/down_trylock/down_nowait/ patches which effect
> > others' changes. Those patches get moved to the end of my queue, and
> > I'll revisit them before an actual merge with Linus.
> >
> > As down_trylock still works (but marked deprecated) with my patches,
> > they're fine to drop. Just tell me which ones...
>
> Well, a simple patch which does
>
> /*
> * comment goes here
> */
> static inline int __must_check down_nowait(struct semaphore *sem)
> {
> return !down_trylock(sem);
> }
>
> and which does not deprecate down_trylock() could go into mainline
> right now

Sure, in this case it's probably worth it.

> , (assuming that the overall concept doesn't get shot down in
> review - did it get reviewed?)

Well, it got some commentry on lkml, mainly from Christoph H. He was the one
who came up with "down_nowait" vs the original "down_try".

> Then you can start trickling stuff out to people straight away.

OK, I'll send a patch now.

Thanks,
Rusty.



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/