[PATCH 45/79] class: rename "interfaces" to "class_interfaces" in internal class structure

From: Greg Kroah-Hartman
Date: Tue Jul 22 2008 - 01:36:46 EST


This renames the struct class "interfaces" field to be
"class_interfaces" to make things easier when struct bus_type and struct
class merge in the future. It also makes grepping for fields easier as
well.

Based on an idea from Kay.

Cc: Kay Sievers <kay.sievers@xxxxxxxx>
Signed-off-by: Greg Kroah-Hartman <gregkh@xxxxxxx>
---
drivers/base/base.h | 4 ++--
drivers/base/class.c | 4 ++--
drivers/base/core.c | 8 ++++----
3 files changed, 8 insertions(+), 8 deletions(-)

diff --git a/drivers/base/base.h b/drivers/base/base.h
index 586c4ca..670b95a 100644
--- a/drivers/base/base.h
+++ b/drivers/base/base.h
@@ -43,7 +43,7 @@ struct driver_private {
* @subsys - the struct kset that defines this class. This is the main kobject
* @children - list of class_devices associated with this class
* @class_devices - list of devices associated with this class
- * @interfaces - list of class_interfaces associated with this class
+ * @class_interfaces - list of class_interfaces associated with this class
* @class_dirs -
* @sem - semaphore to protect the children, devices, and interfaces lists.
* @class - pointer back to the struct class that this structure is associated
@@ -56,7 +56,7 @@ struct driver_private {
struct class_private {
struct kset subsys;
struct list_head class_devices;
- struct list_head interfaces;
+ struct list_head class_interfaces;
struct kset class_dirs;
struct semaphore sem;
struct class *class;
diff --git a/drivers/base/class.c b/drivers/base/class.c
index 9947560..48b518e 100644
--- a/drivers/base/class.c
+++ b/drivers/base/class.c
@@ -144,7 +144,7 @@ int class_register(struct class *cls)
if (!cp)
return -ENOMEM;
INIT_LIST_HEAD(&cp->class_devices);
- INIT_LIST_HEAD(&cp->interfaces);
+ INIT_LIST_HEAD(&cp->class_interfaces);
kset_init(&cp->class_dirs);
init_MUTEX(&cp->sem);
error = kobject_set_name(&cp->subsys.kobj, "%s", cls->name);
@@ -372,7 +372,7 @@ int class_interface_register(struct class_interface *class_intf)
return -EINVAL;

down(&parent->p->sem);
- list_add_tail(&class_intf->node, &parent->p->interfaces);
+ list_add_tail(&class_intf->node, &parent->p->class_interfaces);
if (class_intf->add_dev) {
list_for_each_entry(dev, &parent->p->class_devices, node)
class_intf->add_dev(dev, class_intf);
diff --git a/drivers/base/core.c b/drivers/base/core.c
index 52d1e71..76fdd41 100644
--- a/drivers/base/core.c
+++ b/drivers/base/core.c
@@ -909,8 +909,8 @@ int device_add(struct device *dev)
list_add_tail(&dev->node, &dev->class->p->class_devices);

/* notify any interfaces that the device is here */
- list_for_each_entry(class_intf, &dev->class->p->interfaces,
- node)
+ list_for_each_entry(class_intf,
+ &dev->class->p->class_interfaces, node)
if (class_intf->add_dev)
class_intf->add_dev(dev, class_intf);
up(&dev->class->p->sem);
@@ -1016,8 +1016,8 @@ void device_del(struct device *dev)

down(&dev->class->p->sem);
/* notify any interfaces that the device is now gone */
- list_for_each_entry(class_intf, &dev->class->p->interfaces,
- node)
+ list_for_each_entry(class_intf,
+ &dev->class->p->class_interfaces, node)
if (class_intf->remove_dev)
class_intf->remove_dev(dev, class_intf);
/* remove the device from the class list */
--
1.5.6.3

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/