Re: [PATCH] x86: add apic probe for genapic 64bit v2

From: Ingo Molnar
Date: Tue Jul 22 2008 - 03:13:52 EST



* Ingo Molnar <mingo@xxxxxxx> wrote:

> > v2: fix compiling when CONFIG_ACPI is not set
>
> applied to tip/x86/x2apic - thanks Yinghai.
>
> > +static struct genapic *apic_probe[] __initdata = {
> > + &apic_x2apic_uv_x,
> > + &apic_x2apic_phys,
> > + &apic_x2apic_cluster,
> > + &apic_physflat,
> > + NULL,
> > +};
>
> very nice generalization!

btw.:

apic_probe[i]->acpi_madt_oem_check

should probably be renamed to something more neutral like "->probe" -
there's nothing ACPI about it and some weird boxes could use PCI or
other probing mechanisms to discover the type of APIC they want to use.

plus i guess genapic_32.h and genapic_64.h should be unified and struct
apic_ops should be put into struct genapic?

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/