Re: [PATCH 1/2] x86: rename PTE_MASK to PTE_PFN_MASK

From: Ingo Molnar
Date: Tue Jul 22 2008 - 04:37:00 EST

* Jeremy Fitzhardinge <jeremy@xxxxxxxx> wrote:

> Rusty, in his peevish way, complained that macros defining constants
> should have a name which somewhat accurately reflects the actual
> purpose of the constant.
> Aside from the fact that PTE_MASK gives no clue as to what's actually
> being masked, and is misleadingly similar to the functionally entirely
> different PMD_MASK, PUD_MASK and PGD_MASK, I don't really see what the
> problem is.

Has Rusty ever heard about the economy of the healthy flow of incoming
regressions? What will we do without obscure names and hard to find
bugs? First he writes a simple and readable hypervisor (ruining a whole
industry based on obscurity!) and now that. It's _so_ unamerican and
unaustralian. I'm worried.

Applied to tip/x86/cleanups anyway. Rusty will find out himself how bad
this whole concept of clean and understandable code is, soon enough!

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at