Re: [PATCH 3/3] cpuset: fix wrong calculation of relax domain level

From: Paul Jackson
Date: Tue Jul 29 2008 - 09:11:50 EST


Li Zefan wrote:
> > If so, then perhaps:
> > 1) "update_domain_attr()" could be removed as a separate routine,
> > with its code folded into "update_domain_attr_tree()".
>
> It will be folded into update_domain_attr_tree() by gcc.

My (mild) preference for folding "update_domain_attr()" into
"update_domain_attr_tree()" was not to save runtime CPU cycles.
This is not a hot code path. It was to improve code readability.

Do what you think is best here ... I'm easy.

> I think update_domain_attr_tree() rather than update_domain_attr() needs
> a comment to state what is does, but as it is a helper function for
> rebuild_sched_domains(), I don't think we need to state its locking needs.

Then perhaps one could include in the comment for
"update_domain_attr_tree()" that it is a helper function
for rebuild_sched_domains(), where its locking is described.

--
I won't rest till it's the best ...
Programmer, Linux Scalability
Paul Jackson <pj@xxxxxxx> 1.940.382.4214
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/