Re: [PATCH] power-supply: Add function to return system-wide powerstate

From: Anton Vorontsov
Date: Tue Aug 26 2008 - 16:25:53 EST


On Tue, Aug 26, 2008 at 09:09:59PM +0100, Matthew Garrett wrote:
> (resend, I screwed up the Cc)
>
> Certain drivers benefit from knowing whether the system is on ac or
> battery, for instance when determining which backlight registers to
> read. This adds a simple call to determine whether there's an online
> power supply other than any batteries.

I like the patch, much thanks!

One comment below.

> Signed-off-by: Matthew Garrett <mjg@xxxxxxxxxx>
>
> ---
>
> The name is a bit odd, but seems to fit in with the existing naming
> scheme.
>
> diff --git a/drivers/power/power_supply_core.c b/drivers/power/power_supply_core.c
> index cb1ccb4..6a687da 100644
> --- a/drivers/power/power_supply_core.c
> +++ b/drivers/power/power_supply_core.c
> @@ -87,6 +87,31 @@ int power_supply_am_i_supplied(struct power_supply *psy)
> return error;
> }
>
> +static int __power_supply_is_system_supplied(struct device *dev, void *data)
> +{
> + union power_supply_propval ret = {0,};
> + struct power_supply *psy = dev_get_drvdata(dev);
> +
> + if (psy->type != POWER_SUPPLY_TYPE_BATTERY) {
> + if (psy->get_property(psy,
> + POWER_SUPPLY_PROP_ONLINE, &ret))
> + return 0;
> + if (ret.intval)
> + return ret.intval;
> + }
> + return 0;
> +}
> +
> +int power_supply_is_system_supplied()
> +{
> + int error;
> +
> + error = class_for_each_device(power_supply_class, NULL, NULL,
> + __power_supply_is_system_supplied);
> +
> + return error;
> +}
> +
> int power_supply_register(struct device *parent, struct power_supply *psy)
> {
> int rc = 0;
> @@ -148,6 +173,7 @@ static void __exit power_supply_class_exit(void)
>
> EXPORT_SYMBOL_GPL(power_supply_changed);
> EXPORT_SYMBOL_GPL(power_supply_am_i_supplied);
> +EXPORT_SYMBOL_GPL(power_supply_is_system_supplied);
> EXPORT_SYMBOL_GPL(power_supply_register);
> EXPORT_SYMBOL_GPL(power_supply_unregister);
>
> diff --git a/include/linux/power_supply.h b/include/linux/power_supply.h
> index ea96ead..3e67d0c 100644
> --- a/include/linux/power_supply.h
> +++ b/include/linux/power_supply.h
> @@ -164,6 +164,7 @@ struct power_supply_info {
>
> extern void power_supply_changed(struct power_supply *psy);
> extern int power_supply_am_i_supplied(struct power_supply *psy);
> +extern int power_supply_is_system_supplied(void);

May I suggest adding
static int power_supply_is_system_supplied(void) { return -ENOSYS; }
in case of !CONFIG_POWER_SUPPLY? This way drivers may not strictly
depend on power supply class.

And "if (power_supply_is_system_supplied())" will assume that we're
always supplied, which good assumption, I think.

Thanks,

--
Anton Vorontsov
email: cbouatmailru@xxxxxxxxx
irc://irc.freenode.net/bd2
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/