Re: [PATCH] x86: trim ACPI sleep stack buffer

From: Len Brown
Date: Thu Oct 09 2008 - 15:36:08 EST


applied (before the stack change patch:-) to acpi-test

thanks,
-Len

On Thu, 9 Oct 2008, Pavel Machek wrote:

> On Thu 2008-10-09 12:41:50, Matt Mackall wrote:
> > On Thu, 2008-10-09 at 10:23 -0700, Moore, Robert wrote:
> > > Sounds like you need a
> > >
> > > #define DEFAULT_STACK_SIZE 4096
> > >
> > > Somewhere.
> >
> > Or maybe something like this:
> >
> >
> > x86: remove magic number from ACPI sleep stack buffer
> >
> > Signed-off-by: Matt Mackall <mpm@xxxxxxxxxxx>
>
> Acked-by: Pavel Machek <pavel@xxxxxxx>
>
> > diff -r 375a00b8bf10 arch/x86/kernel/acpi/sleep.c
> > --- a/arch/x86/kernel/acpi/sleep.c Thu Oct 09 12:38:55 2008 -0500
> > +++ b/arch/x86/kernel/acpi/sleep.c Thu Oct 09 12:40:10 2008 -0500
> > @@ -97,7 +97,7 @@
> > #else /* CONFIG_64BIT */
> > header->trampoline_segment = setup_trampoline() >> 4;
> > #ifdef CONFIG_SMP
> > - stack_start.sp = temp_stack + 4096;
> > + stack_start.sp = temp_stack + sizeof(temp_stack);
> > #endif
> > initial_code = (unsigned long)wakeup_long64;
> > saved_magic = 0x123456789abcdef0;
> >
> >
>
> --
> (english) http://www.livejournal.com/~pavelmachek
> (cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/