Re: [PATCH 3/6] vfs: add __d_instantiate() helper

From: OGAWA Hirofumi
Date: Wed Oct 15 2008 - 16:40:16 EST


Christoph Hellwig <hch@xxxxxxxxxxxxx> writes:

> On Wed, Oct 15, 2008 at 10:58:10PM +0900, OGAWA Hirofumi wrote:
>>
>> This adds __d_instantiate() for users which is already taking
>> dcache_lock, and replace with it.
>>
>> The part of d_add_ci() isn't equivalent. But it should be needed
>> fsnotify_d_instantiate() actually, because the path is to add the
>> inode to negative dentry. fsnotify_d_instantiate() should be called
>> after change from negative to positive.
>>
>> __d_instantiate_unique() and d_materialise_unique() does opencoded
>> optimized version. From history, it seems a intent, so just add comment.
>
> Looks good, but I think those "optimized' version should also be
> converted, a single if shouldn't matter with todays branch predictors.

Me too.

Trond, do you care the following convert? E.g.

in d_materialise_unique():

from
dentry->d_inode = NULL;
goto found_lock;
to
__d_instantiate(dentry, NULL);
goto found_lock;
--
OGAWA Hirofumi <hirofumi@xxxxxxxxxxxxxxxxxx>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/