Re: [PATCH 3/6] rz1000: apply chipset quirks early

From: Sergei Shtylyov
Date: Tue Nov 04 2008 - 13:56:36 EST


Hello, I wrote:

Index: b/drivers/ide/rz1000.c
===================================================================
--- a/drivers/ide/rz1000.c
+++ b/drivers/ide/rz1000.c
@@ -22,34 +22,48 @@
#define DRV_NAME "rz1000"
-static void __devinit init_hwif_rz1000 (ide_hwif_t *hwif)
+static unsigned int __devinit rz1000_init_chipset(struct pci_dev *dev)

Hm, this is not a real init_chipset() method and it does just one thing -- disables readahead, so rz1000_disable_readahead() or something of that sort seems like a better name...

Hm, 'unsigned' result type wasn't terribly helpful here as well. :-)

MBR, Sergei
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/