Re: [PATCH v2 2/5] x86: ia32_signal: introduce COPY_SEG_STRICT

From: Ingo Molnar
Date: Tue Nov 18 2008 - 10:56:43 EST



* Hiroshi Shimamoto <h-shimamoto@xxxxxxxxxxxxx> wrote:

> H. Peter Anvin wrote:
> > Hiroshi Shimamoto wrote:
> >> From: Hiroshi Shimamoto <h-shimamoto@xxxxxxxxxxxxx>
> >>
> >> Impact: cleanup
> >>
> >> Introduce COPY_SEG_STRICT for ia32_restore_sigcontext().
> >>
> >
> > I don't like the name _STRICT() for this; if anything it seems to have
> > quite the opposite meaning. I would suggest COPY_SEG_USER() or even
> > COPY_SEG_CPL3().
>
> Sounds nice.
> I haven't thought about the name. I could not catch wrong meaning from
> _STRICT. My English skill isn't good.

i have changed it to COPY_SEG_CPL3() - no need to resend. Here are the
patches i've picked up into tip/x86/signal:

6497760: x86: ia32_signal: change order of storing in setup_sigcontext()
047ce93: x86: ia32_signal: remove using temporary variable
8c6e5ce: x86: ia32_signal: cleanup macro RELOAD_SEG
d71a68d: x86: ia32_signal: introduce COPY_SEG_CPL3
b78a5b5: x86: ia32_signal: cleanup macro COPY

thanks!

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/