Re: ext4 no space left

From: Theodore Tso
Date: Wed Jan 21 2009 - 09:55:30 EST

On Wed, Jan 21, 2009 at 03:19:28PM +0100, Victor Pelt wrote:
> Hey,
> i tried to switch my root partition to ext4 (from reiserfs) but i ran
> into problems when copying over all the data that it says 'no space
> left on the device'
> i'm running 2.6.28-gentoo-r1 (based on if i'm not mistaken)
> rootfs 5044188 4310972 476980 91% / <= file
> system that is 'full'
> i like to use that last 470MB if possible
> fsck didn't help (tried that)

If this is the problem I think it is, it's fixed in patches that were
merged for 2.6.29 (in -rc1), and you can work around it via umounting
and remounting the filesystem (or in case of the root filesystem,

However, when you said "fsck didn't help", what exactly did you mean
by that? That fsck didn't show any problems, when you ran it while
the filesystem was mounted? Did you actually reboot and force an
fsck, and then found that you were still getting ENOSPC errors?

I assume you have tried writing as root, and that quotas are disabled?

- Ted

P.S. If it is the problem I think it is, upgrading 2.6.29-rcX should
fix the problem, as would using the ext4-stable branch in the ext4 git
tree, or applying the patches in the for-stable branch of the ext4 git
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at