Re: [PATCH 7/9] ide: move ->rqsize init from init_irq() to ide_init_port()

From: Bartlomiej Zolnierkiewicz
Date: Thu Jan 22 2009 - 09:53:13 EST



Hi,

On Wednesday 14 January 2009, Bartlomiej Zolnierkiewicz wrote:
> On Sunday 11 January 2009, Sergei Shtylyov wrote:
> > Hello.
> >
> > Bartlomiej Zolnierkiewicz wrote:
> >
> > > Signed-off-by: Bartlomiej Zolnierkiewicz <bzolnier@xxxxxxxxx>
> > >
> >
> > > Index: b/drivers/ide/ide-probe.c
> > > ===================================================================
> > > --- a/drivers/ide/ide-probe.c
> > > +++ b/drivers/ide/ide-probe.c
> > >
> > [...]
> > > @@ -1242,6 +1234,13 @@ static void ide_init_port(ide_hwif_t *hw
> > >
> > > if (d->max_sectors)
> > > hwif->rqsize = d->max_sectors;
> > > + else {
> > > + if ((hwif->host_flags & IDE_HFLAG_NO_LBA48) ||
> > > + (hwif->host_flags & IDE_HFLAG_NO_LBA48_DMA))
> > >
> >
> > Er, why not:
> >
> > if (hwif->host_flags &
> > (IDE_HFLAG_NO_LBA48 | IDE_HFLAG_NO_LBA48_DMA))
>
> IMO it is harder to read

Sigh, why we were focused on subtle CodingStyle preferences we missed
the real issue...

This patch depends on fact that all host drivers use struct ide_port_info
which is not true yet (icside, buddha, ide_arm, ide-generic, ide-pnp and
macide still needs to be updated). I dropped it from pata-2.6 for now...

Thanks,
Bart
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/