Re: [PATCH 1/3] sched: code cleanup - sd_power_saving_flags(),sd_balance_for_mc/package_power()

From: Peter Zijlstra
Date: Mon Feb 16 2009 - 12:43:25 EST


On Mon, 2009-02-16 at 22:21 +0530, Gautham R Shenoy wrote:

> +enum sched_domain_level {
> + SD_LV_NONE = 0,
> + SD_LV_SIBLING,
> + SD_LV_MC,
> + SD_LV_CPU,
> + SD_LV_NODE,
> + SD_LV_ALLNODES,
> + SD_LV_MAX
> +};


Better names would be:

LV_THREAD
LV_CORE
LV_PACKAGE
LV_NODE

But I realize that renaming these is going to be painful, however could
we at least provide proper comments with these to describe them. I
always get confused.


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/