Re: [tip:perfcounters/core] perf_counter, x86: renamecpuc->active_mask

From: Ingo Molnar
Date: Wed Apr 29 2009 - 09:17:42 EST



* tip-bot for Robert Richter <robert.richter@xxxxxxx> wrote:

> Commit-ID: 93904966934193204ad08e951f806d5631c29eb3
> Gitweb: http://git.kernel.org/tip/93904966934193204ad08e951f806d5631c29eb3
> Author: Robert Richter <robert.richter@xxxxxxx>
> AuthorDate: Wed, 29 Apr 2009 12:47:15 +0200
> Committer: Ingo Molnar <mingo@xxxxxxx>
> CommitDate: Wed, 29 Apr 2009 14:51:09 +0200
>
> perf_counter, x86: rename cpuc->active_mask
>
> This is to have a consistent naming scheme with cpuc->used.
>
> [ Impact: cleanup ]
>
> Signed-off-by: Robert Richter <robert.richter@xxxxxxx>
> Cc: Paul Mackerras <paulus@xxxxxxxxx>
> Acked-by: Peter Zijlstra <a.p.zijlstra@xxxxxxxxx>
> LKML-Reference: <1241002046-8832-19-git-send-email-robert.richter@xxxxxxx>
> Signed-off-by: Ingo Molnar <mingo@xxxxxxx>
>
>
> ---
> arch/x86/kernel/cpu/perf_counter.c | 10 +++++-----
> 1 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/arch/x86/kernel/cpu/perf_counter.c b/arch/x86/kernel/cpu/perf_counter.c
> index 3f3ae47..9ec51a6 100644
> --- a/arch/x86/kernel/cpu/perf_counter.c
> +++ b/arch/x86/kernel/cpu/perf_counter.c
> @@ -29,9 +29,9 @@ static u64 perf_counter_mask __read_mostly;
> struct cpu_hw_counters {
> struct perf_counter *counters[X86_PMC_IDX_MAX];
> unsigned long used[BITS_TO_LONGS(X86_PMC_IDX_MAX)];
> + unsigned long active[BITS_TO_LONGS(X86_PMC_IDX_MAX)];
> unsigned long interrupts;
> u64 throttle_ctrl;
> - unsigned long active_mask[BITS_TO_LONGS(X86_PMC_IDX_MAX)];
> int enabled;
> };

Note, i applied this because later patches had dependencies - but
could you please send a followup patch that renames both ->used and
->active to ->used_mask and ->active_mask?

Thanks,

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/