Re: introducing __GFP_PANIC

From: Pekka Enberg
Date: Mon May 04 2009 - 05:57:38 EST


On Mon, 2009-05-04 at 13:08 +0400, Cyrill Gorcunov wrote:
> Index: linux-2.6.git/mm/oom_kill.c
> =====================================================================
> --- linux-2.6.git.orig/mm/oom_kill.c
> +++ linux-2.6.git/mm/oom_kill.c
> @@ -422,6 +422,16 @@ static int oom_kill_process(struct task_
> return oom_kill_task(p);
> }
>
> +void oom_panic(gfp_t gfp_mask, unsigned int order)
> +{
> + if (likely(!(gfp_mask & __GFP_PANIC)))
> + return;
> +
> + panic("Out of memory: panic due to __GFP_PANIC.\n"
> + "%s order:%d, mode:0x%x\n", current->comm,
> + order, gfp_mask);
> +}

I think this just makes things harder to follow. It has one call-site so
why not inline this there?

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/