Re: [PATCH 3/10 -tip] x86: Add cpufeatures for Advanced PowerManagement

From: Thomas Gleixner
Date: Tue May 12 2009 - 17:05:50 EST


Jaswinder,

On Wed, 13 May 2009, Jaswinder Singh Rajput wrote:
> + /* Advanced Power Management (Function 8000_0007h), edx */
> + if (c->extended_cpuid_level >= 0x80000007) {
> + c->x86_capability[9] = cpuid_edx(0x80000007);

In the reply to [Patch 5/10] Ingo wrote:
>> Also, open-coding x86_capability[9] like that is quite unclean. Were
>> we ever to reorder those bits internally, this could would break.

Do you really believe that open-coding x86_capability[9] in .../common.c
is better than the open-coding in ../powernow-k8.c ?

Again, open-coding is wrong and error prone. Ingo explicitely asked for a
helper function. All you did is moving the open-coded hard wired array
reference to a different place.

Please start to listen to the review comments as long as people are
willing to look at your patches. Seriously, the noise/useful ratio of
your patches is annoying and adds an unjustified burden to the
maintainers of that code.

Thanks,

tglx
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/