Re: [PATCH 3/10 -tip] x86: Add cpufeatures for Advanced PowerManagement

From: Jaswinder Singh Rajput
Date: Wed May 13 2009 - 04:58:23 EST


On Tue, 2009-05-12 at 23:04 +0200, Thomas Gleixner wrote:
> Jaswinder,
>
> On Wed, 13 May 2009, Jaswinder Singh Rajput wrote:
> > + /* Advanced Power Management (Function 8000_0007h), edx */
> > + if (c->extended_cpuid_level >= 0x80000007) {
> > + c->x86_capability[9] = cpuid_edx(0x80000007);
>
> In the reply to [Patch 5/10] Ingo wrote:
> >> Also, open-coding x86_capability[9] like that is quite unclean. Were
> >> we ever to reorder those bits internally, this could would break.
>
> Do you really believe that open-coding x86_capability[9] in .../common.c
> is better than the open-coding in ../powernow-k8.c ?
>
> Again, open-coding is wrong and error prone. Ingo explicitely asked for a
> helper function. All you did is moving the open-coded hard wired array
> reference to a different place.
>
> Please start to listen to the review comments as long as people are
> willing to look at your patches. Seriously, the noise/useful ratio of
> your patches is annoying and adds an unjustified burden to the
> maintainers of that code.
>

Ok, trashed complete cpu_debug and cpufeature patches, I hope it will
makes maintainers happy and save their precious time.

Anyway thanks for being so helpful and making my task easier :-)

--
JSR

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/