Re: [PATCH 1/1] ptrace: wait_task_zombie: s/->parent/->real_parent/

From: Roland McGrath
Date: Tue May 26 2009 - 16:24:34 EST

> Change wait_task_zombie() to use ->real_parent instead of ->parent.

Acked-by: Roland McGrath <roland@xxxxxxxxxx>

> We could even use current afaics, but ->real_parent is more clean.

Indeed, though the caller might not be ->real_parent, it will always be
one that shares ->signal with ->real_parent. But I agree that using
->real_parent is the clean way. Incidentally, as readability cleanup it
would make a lot of sense to move that block into a subroutine.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at