Re: [RFC PATCH 3/X] ptrace: introduce the empty "structptrace_task"

From: Roland McGrath
Date: Tue May 26 2009 - 16:34:27 EST

> Please use 'struct ptrace_context' and '*ptrace_ctx' instead.

I am fine with this name (or any other). But note in considering your
suggestions that we will shortly have another separate struct with a
similar name. The first one is the state of a ptrace tracee task (bits
about itself and pointing to its tracer). The second is the state of a
ptrace tracer (head of its tracees list, locks, etc).

A name like "ptrace_context" could be read as intuitive for either of these
two quite different things. Perhaps this is true of "ptrace_task" too,
though it seemed to us like it wasn't too unclear, and preferably shorter
than something like "ptrace_tracee_context".

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at