Re: [PATCH 1/3] clean up functions related to pages_min V2
From: Minchan Kim
Date: Wed May 27 2009 - 07:30:38 EST
On Tue, 26 May 2009 22:25:10 -0700
Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> wrote:
> On Thu, 21 May 2009 09:23:04 +0900 Minchan Kim <minchan.kim@xxxxxxxxx> wrote:
> > Changelog since V1
> > o Change function name from setup_per_zone_wmark_min to setup_per_zone_wmarks
> > - by Mel Gorman advise
> > o Modify description - by KOSAKI advise
> > Mel changed zone->pages_[high/low/min] with zone->watermark array.
> > So, the functions related to pages_min also have to be changed.
> > * setup_per_zone_pages_min
> > * init_per_zone_pages_min
> > This patch is just clean up. so it doesn't affect behavior.
> I cannot actually find a usable changelog amongst all that text. Can
> you try again please?
> afacit the patch simply changes the names of a couple of functions.
> The changelog should concisely and completely describe what those naming
> changes are, and the reason for making them.
I will add just description of patch since Andrew already merged this patch
== CUT_HERE ==
This patch change names of two functions. so It doesn't affect behavior.
Now, setup_per_zone_pages_min changes low, high of zone as well as min.
So, a better name might have been setup_per_zone_wmarks.That's because
Mel changed zone->pages_[hig/low/min] to zone->watermark array.(434b5394fd85c212619306cda6bf087be737b35a)
* setup_per_zone_pages_min => setup_per_zone_wmarks
Of course, we have to change init_per_zone_pages_min, too.
There are not pages_min any more.
* init_per_zone_pages_min => init_per_zone_wmark_min
Signed-off-by: Minchan Kim <minchan.kim@xxxxxxxxx>
Acked-by: Mel Gorman <mel@xxxxxxxxx>
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/