Re: [PATCH 1/3] clean up functions related to pages_min V2

From: Andrew Morton
Date: Wed May 27 2009 - 16:40:47 EST

On Wed, 27 May 2009 20:29:55 +0900
Minchan Kim <> wrote:

> This patch change names of two functions. so It doesn't affect behavior.
> Now, setup_per_zone_pages_min changes low, high of zone as well as min.
> So, a better name might have been setup_per_zone_wmarks.That's because
> Mel changed zone->pages_[hig/low/min] to zone->watermark array.(434b5394fd85c212619306cda6bf087be737b35a)

When quoting changeset IDs, please do it in the form

0594ad1a66381076f0fa06f5605ea5023f600586 ("mfd/pcf50633-gpio.c: add MODULE_LICENSE")

There's a good reason for this, but I forget what it is. Perhaps so
that the same commit can be located if it has a different hash? I
expect that commits get a different hash when backported into -stable,
for example.

I spend my life making changes like that to changelogs, but when I went
to fix up your 434b5394fd85c212619306cda6bf087be737b35a, I was unable
to locate any commit which has that hash.

<searches for a while>

Ah, you're referring to a -mmotm patch. The hashes in -mmotm aren't
useful because the tree gets regenerated each time. So let's refer to
that patch via just its title, "page allocator: replace the
watermark-related union in struct zone with a watermark[] array".

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at