Re: Analyzed/Solved/Bisected: Booting 2.6.30-rc2-git7 very slow

From: Martin Knoblauch
Date: Thu May 28 2009 - 05:14:55 EST

Martin Knoblauch
email: k n o b i AT knobisoft DOT de

----- Original Message ----
> From: Kay Sievers <kay.sievers@xxxxxxxx>
> To: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx>
> Cc: Martin Knoblauch <knobi@xxxxxxxxxxxx>; efault@xxxxxx; viro@xxxxxxxxxxxxxxxxxx; rjw@xxxxxxx; linux-kernel@xxxxxxxxxxxxxxx; shemminger@xxxxxxxxxx; jbarnes@xxxxxxxxxxxxxxxx; matthew@xxxxxx; mike.miller@xxxxxx
> Sent: Wednesday, May 27, 2009 10:56:45 PM
> Subject: Re: Analyzed/Solved/Bisected: Booting 2.6.30-rc2-git7 very slow
> On Wed, May 27, 2009 at 22:31, Andrew Morton wrote:
> > On Wed, 27 May 2009 04:25:57 -0700 (PDT)
> > Martin Knoblauch wrote:
> >
> >> FWIW, I compiled the CCISS driver into the kernel. This makes the second
> "/sys" line in /proc/mounts go away, dmesg attached. But does it prove anything?
> The initialization of the CCISS hardware now happens about 2 seconds earlier in
> the bootup sequence. Does this hint to a problem with CCISS, or just confirms
> that the whole issue is really timing dependent? Anyway, I add Mike to CC.
> >>
> >
> > It seems that the PCI change caused timing changes which triggered a
> > udev/sysfs/whatever problem, which manifests as the duplicated
> > /proc/mounts entry to turn up.
> >
> > What we don't know (afaik) is why the kernel permitted two entries in
> > /proc/mounts. That might be a bug.
> >
> > It could be that if dual /proc/mounts problem gets fixed, everything
> > works OK - by intent or by accident, the userspace startup scripts may
> > then work acceptably.
> >
> > I think Al asked you a few questions around the behaviour of mount(8)
> > and the mount syscall, so we could delve further into why /proc/mounts
> > is getting mucked up. Did you end up running those tests?

I do not recall any questions from Al. If he asked, I am pretty sure I answered :-)

> I expect the duplicate comes from a left-over mount in initramfs which
> isn't a duplicate in the sense of a bug in vfs or mount or anything. I
> guess, it is just still mounted in the initial kernel rootfs, below
> the root from the disk. It could be that a umount from initramfs did
> go wrong because of a changed timing.

This is what I suspect as well. I know for sure that the first sysfs-line in /proc/mounts

| none /sys sysfs rw 0 0

is already there (2.6.29-rc1 and up) when entering startup-skripts. It is supposed to be unmounted before, but something seems to prevent it. I have idea how to capture debug output from the initrd/init script :-(


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at