Re: [my_cpu_ptr 1/5] Introduce my_cpu_ptr()
From: Christoph Lameter
Date: Thu May 28 2009 - 12:38:29 EST
On Thu, 28 May 2009, Christoph Hellwig wrote:
> On Thu, May 28, 2009 at 01:16:01PM +0930, Rusty Russell wrote:
> > On Thu, 28 May 2009 03:16:59 am cl@xxxxxxxxxxxxxxxxxxxx wrote:
> > > my_cpu_ptr(xx) = per_cpu_ptr(xx, smp_processor_id).
> > I had this implemented earlier as as get_cpu_ptr()/__get_cpu_ptr(), to match
> > get_cpu_var() / __get_cpu_var().
> > But other than that nomenclature quibble, it looks fine!
> my_ seems a very odd naming. We have a lot of this_cpu naming for the
> current cpu i nthe ctree, so I would suggest sticking to that.
So this_cpu is taken. I used THIS_CPU in earlier version
but got complaints about uppercase use. Is
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/