Re: [PATCH 1/6] cpumask: introduce zalloc_cpumask_var

From: Yinghai Lu
Date: Sat Jun 06 2009 - 18:08:26 EST


Andrew Morton wrote:
> On Sat, 06 Jun 2009 14:50:36 -0700 Yinghai Lu <yinghai@xxxxxxxxxx> wrote:
>
>> bool alloc_cpumask_var_node(cpumask_var_t *mask, gfp_t flags, int node);
>> bool alloc_cpumask_var(cpumask_var_t *mask, gfp_t flags);
>> +bool zalloc_cpumask_var_node(cpumask_var_t *mask, gfp_t flags, int node);
>> +bool zalloc_cpumask_var(cpumask_var_t *mask, gfp_t flags);
>> void alloc_bootmem_cpumask_var(cpumask_var_t *mask);
>
> ick. cpumask_var_node_zalloc() would be better.
>
> Yes, the other functions were incorrectly named, but that's no reason
> to incorrectly name these also.

problem is that we would using alloc_cpumask_var and zalloc_cpumask in different case.

so we may need to change these name at the same time. otherwise will cause confusing. No?

YH
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/