Re: [PATCH] PCI: remove pcibios_scan_all_fns()

From: Jeremy Fitzhardinge
Date: Mon Jun 22 2009 - 14:20:40 EST


On 06/22/09 07:34, Matthew Wilcox wrote:
> On Mon, Jun 22, 2009 at 08:08:07AM -0600, Alex Chiang wrote:
>
>> This was #define'd as 0 on all platforms, so let's get rid of it.
>>
>> This change makes pci_scan_slot() slightly easier to read.
>>
>
>
>> diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
>> index f1ae247..b613cad 100644
>> --- a/drivers/pci/probe.c
>> +++ b/drivers/pci/probe.c
>> @@ -1056,8 +1056,7 @@ int pci_scan_slot(struct pci_bus *bus, int devfn)
>> if (dev && !dev->is_added) /* new device? */
>> nr++;
>>
>> - if ((dev && dev->multifunction) ||
>> - (!dev && pcibios_scan_all_fns(bus, devfn))) {
>> + if (dev && dev->multifunction) {
>> for (fn = 1; fn < 8; fn++) {
>> dev = pci_scan_single_device(bus, devfn + fn);
>> if (dev) {
>>
>
> What a good idea. I was just looking at making this more complicated
> (due to the ARI capability).
>
> I'd like to know what the KVM / Xen / ... people think about this.
> I don't know if they rely on function 5 being able to show up out of
> the blue.
>

We want to be able to export specific functions to a particular domain,
so it might see a PCI device with only function 5.

It looks like we lose that ability with this patch, is that right?

J
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/