Re: [PATCH] I/OAT: Convert to PCI_VDEVICE()

From: Joe Perches
Date: Wed Jul 01 2009 - 15:12:29 EST


On Wed, 2009-07-01 at 11:12 -0700, Roland Dreier wrote:
> Trivial cleanup to make the PCI ID table easier to read.

Should this be done tree-wide?

Maybe there should be some new #defines like:

#define PCI_NAMED_DEVICE(vendor, device) \
PCI_DEVICE(PCI_VENDOR_ID_##vendor, PCI_DEVICE_ID_##vendor##_##device)

#define PCI_UNNAMED_DEVICE(vendor, device) \
PCI_DEVICE(PCI_VENDOR_ID_##vendor, device)


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/