Re: [patch -mm v2] mm: introduce oom_adj_child

From: David Rientjes
Date: Thu Jul 30 2009 - 05:31:22 EST


On Thu, 30 Jul 2009, KAMEZAWA Hiroyuki wrote:

> 1. IIUC, the name is strange.
>
> At job scheduler, which does this.
>
> if (vfork() == 0) {
> /* do some job */
> execve(.....)
> }
>
> Then, when oom_adj_child can be effective is after execve().
> IIUC, the _child_ means a process created by vfork().
>

It's certainly a difficult thing to name and I don't claim that "child" is
completely accurate since, as you said, vfork'd tasks are also children
of the parent yet they share the same oom_adj value since it's an
attribute of the shared mm.

If you have suggestions for a better name, I'd happily ack it.

> 2. More simple plan is like this, IIUC.
>
> fix oom-killer's select_bad_process() not to be in deadlock.
>

Alternate ideas?

> rather than this new stupid interface.
>

Well, thank you. Regardless of whether you think it's stupid or not, it
doesn't allow you to livelock the kernel in a very trivial way when the
oom killer gets invoked prior to execve() and the parent is OOM_DISABLE.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/