Re: [RFC v17][PATCH 16/60] pids 6/7: Define do_fork_with_pids()

From: Serge E. Hallyn
Date: Mon Aug 03 2009 - 14:27:10 EST


Quoting Oren Laadan (orenl@xxxxxxxxxxx):
> From: Sukadev Bhattiprolu <sukadev@xxxxxxxxxxxxxxxxxx>
...
> +struct target_pid_set {
> + int num_pids;
> + pid_t *target_pids;
> +};

Oren, I thought you had decided to add an extended flags field
here, to support additional CLONE_ flags - such as CLONE_TIMENS?

I mention it now because if you're still considering that
long-term, then IMO the syscall should not be called clone_with_pids(),
but clone_extended(). Otherwise, to support new clone flags we'll
either have to use unshare2 (without clone support), or add yet
another clone variant, OR use clone_with_pids() which is a poor name
for something which will likely be used in cases without specifying
pids, but specifying flags not support through any other interface.

-serge
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/