Re: [PATCH V2] au1xmmc: dev_pm_ops conversion

From: Rafael J. Wysocki
Date: Mon Aug 03 2009 - 15:22:46 EST


On Monday 03 August 2009, Albin Tonnerre wrote:
> On Sat, Jul 25, 2009, Frans Pop wrote:
> > Yes, I see that in drivers/base/platform.c (legacy) .suspend resp. .resume
> > also got called for those cases?
> > Ouch :-(
>
> This really looks like it's error-prone (I made this mistake for atmel_serial
> and wouldn't have noticed if Frans hadn't told me), and AFAICS, for a number of
> drivers we'll have suspend = freeze = poweroff and resume = thaw = restore.
> Maybe putting something like this in pm.h would help ?
>
> #define PM_OPS(name, suspend, resume) \
> struct dev_pm_ops name = { \
> .suspend = suspend, \
> .resume = resume, \
> .freeze = suspend, \
> .thaw = resume, \
> .poweroff = suspend, \
> .restore = resume, \
> };

That looks like a good idea, but please call that macro SIMPLE_PM_OPS (or
something similar) and submit a patch.

Best,
Rafael
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/