Re: [PATCH] libata: Add pata_atp867x driver for Artop/Acard ATP867X controllers

From: Jung-Ik (John) Lee
Date: Sat Sep 12 2009 - 20:37:34 EST


On Sat, Sep 12, 2009 at 5:31 PM, Jeff Garzik <jgarzik@xxxxxxxxx> wrote:
> On 09/12/2009 08:26 PM, Jung-Ik (John) Lee wrote:
>>
>> From: John(Jung-Ik) Lee<jilee@xxxxxxxxxx>
>>
>> This is a new pata driver for ARTOP 867X 64bit 4-channel UDMA133 ATA
>> ctrls.
>> Based on the Atp867 data sheet rev 1.2, Acard, and in part on early ide
>> codes
>> from Eric Uhrhane<ericu@xxxxxxxxxx>.
>>
>> Signed-off-by: John(Jung-Ik) Lee<jilee@xxxxxxxxxx>
>> Reviewed-by:  Grant Grundler<grundler@xxxxxxxxxx>
>> Reviewed-by:  Gwendal Gringo<gwendal@xxxxxxxxxx>
>> ---
>>
>>  drivers/ata/Kconfig        |    9 +
>>  drivers/ata/Makefile       |    1 +
>>  drivers/ata/pata_atp867x.c |  578
>> ++++++++++++++++++++++++++++++++++++++++++++
>>  include/linux/pci_ids.h    |    2 +
>>  4 files changed, 590 insertions(+), 0 deletions(-)
>
> What changed in this patch, versus previous patches?

Only one change - removed the hard-coded value for active/recovery.

-+#ifdef ATP867X_NO_HACK_PIOMODE
+ b = atp867x_get_active_clocks_shifted(t.active) |
+ atp867x_get_recover_clocks_shifted(t.recover);
-+#else
-+ /*
-+ * magic value that works (from doc 6.4, 6.6.9)
-+ */
-+ b = 0x31;
-+#endif
+ if (dp->pci66mhz)
+ b += 0x10;
+


>
> (that's a question, and also an indication of what needs to be explicitly
> stated in your email body, immediately following the "---" separator, for
> each patch revision)
>

I'll send another with rev change.
-John


> Since the merge window is open, I will likely send this driver upstream as
> soon as feedback level approaches zero.
>
>        Jeff
>
>
>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/