Re: [PATCH 9/12] ACPI / PM: Introduce acpi_pm_wakeup_power()

From: Jesse Barnes
Date: Wed Jan 06 2010 - 17:00:43 EST


On Sun, 27 Dec 2009 21:06:26 +0100
"Rafael J. Wysocki" <rjw@xxxxxxx> wrote:
> /**
> + * acpi_pm_wakeup_power - Enable/disable device wake-up power.
> + * @dev: ACPI device to handle.
> + * @enable: Whether to enable or disable the wake-up power of the
> device.
> + */
> +int acpi_pm_wakeup_power(struct acpi_device *dev, bool enable)
> +{

I know we've got these all over now, but functions that just take a
bool are generally hard to read when you just look at the call site.
If it was called "acpi_pm_set_wakeup_power" and then took an on/off
enum it would be really easy to see, from the callsite, what was going
on.

It's a fairly minor complaint, but it's something that's always bugged
me about the PCI PM code in particular.

--
Jesse Barnes, Intel Open Source Technology Center
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/