Re: [PATCH] [1/9] Add rcustring ADT for RCU protected strings v2

From: Andrew Morton
Date: Fri Jan 08 2010 - 18:51:14 EST


On Tue, 5 Jan 2010 03:15:26 +0100 (CET)
Andi Kleen <andi@xxxxxxxxxxxxxx> wrote:

> +extern char *alloc_rcu_string(int size, gfp_t gfp);
> +extern void free_rcu_string(const char *string);
> +
> +/*
> + * size must be the same as alloc_rcu_string, don't
> + * use strlen on str!
> + */
> +extern char *access_rcu_string(char **str, int size, gfp_t gfp);

I think better names would be rcu_string_alloc(), rcu_string_free() and
rcu_string_access().

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/