Re: [PATCH] regulator: mc13783: consider Power Gates as digitalregulators.
From: Uwe Kleine-König
Date: Mon Jan 18 2010 - 14:04:57 EST
Can you post an updated patch addressing the discussion with Mark,
>From the first look I don't like the name
MC13783_REG_POWERMISC_PWGTSPI_M as I don't understand it's purpose
without going through mc13783_reg_rmw_powermisc (which I didn't do yet).
What is the base for your patch? (Hm, it seems next could work.
mc13783-regulator seems to have gotten some more #defines ending in _M.
You seem to mean "mask". IMHO it's a bit unfortunate, because the
nameing scheme doesn't match the already existing names :-()
Shouldn't mc13783_state_powermisc_pwgt be a per-device variable instead
of a static variable?
Pengutronix e.K. | Uwe Kleine-König |
Industrial Linux Solutions | http://www.pengutronix.de/ |
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/