Re: [PATCH 22/37] move round_up/down to kernel.h

From: Christoph Lameter
Date: Wed Jan 20 2010 - 15:54:43 EST


On Wed, 20 Jan 2010, Yinghai Lu wrote:

> like this, using DIVIDE for all ?

I liked the __round_mask better


> -#define __round_mask(x,y) ((__typeof__(x))((y)-1))
> -#define round_up(x,y) ((((x)-1) | __round_mask(x,y))+1)
> -#define round_down(x,y) ((x) & ~__round_mask(x,y))
> +#define roundup(x, y) ((((x) + ((y) - 1)) / (y)) * (y))
> +#define rounddown(x, y) (((x) / (y)) * (y))

> +#define round_up(x,y) roundup(x,y)
> +#define round_down(x,y) rounddown(x,y)

Why two aliases? Make the use consistent throughout the source.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/