On Thu, 21 Jan 2010, Haicheng Li wrote:
Nack, we don't need to add yet another nodemask because you're havingHey Dave, why do you think it's just a naming issue?
trouble finding a new name for a cpu_nodes_parsed. It would be perfectly
What I'm concerning is that your assumption of cpu_nodes_parsed use is wrong,
cpu_nodes_parsed is needed anyway since its semantics represent the node with
cpu affinity rather than memless node, that's also why I originally doubted
cpu_node_parsed cannot handle hotplug node.
Wrong, cpu_nodes_parsed (despite its name) solely represents nodes that do not have online address memory ranges. That's it. Nothing more, nothing less. That's why I suggest you rename it to no_mem_nodes or something similar. Look at the single time that the nodemask is used: to set cleared bits in node_possible_map that were not set in nodes_parsed because THEY DO NOT HAVE ASSOCIATED ONLINE MEMORY RANGES, the _only_ time a node gets set in nodes_parsed.
Once you rename nodes_parsed to mem_nodes and cpu_nodes_parsed to no_mem_nodes, it may become clearer.
we also need hp_nodes_parsed to represent the node with hotpluggable memory
region, just like why we need nodes_parsed to repsent node with mem on.
It's pointless to add another nodemask, the semantics of cpu_nodes_parsed is perfectly legitimate for hotpluggable nodes as well. Instead of fixating on the name, look at the code that uses it.