Re: dumpe2fs/dump/restore not working correctly for ext4?

From: Justin Piszcz
Date: Thu Mar 04 2010 - 17:21:47 EST

On Thu, 4 Mar 2010, tytso@xxxxxxx wrote:

On Thu, Mar 04, 2010 at 10:19:57AM -0500, Justin Piszcz wrote:

I need to look into this more obviously and try other dumps etc, but
I even tried extracting a single (smaller) directory and it also
segfaulted, has dump been tested properly with ext4?

Was dump/restore statically or dynamically linked? And with which
version of libext2fs from e2fsprogs?

- Ted


I tried restoring from two different datasets on one machine <10GB and another
one ~30GB, all files are corrupted, other users report the same problem:

Per your requests:

They are dynamically linked.
This is standard Debian Testing x86_64, nothing custom (in the distribution).

p34:~# ldd `which dump` => (0x00007fff93192000) => /lib/ (0x00007f0bdf559000) => /lib/ (0x00007f0bdf356000) => /lib/ (0x00007f0bdf141000) => /lib/ (0x00007f0bdef3d000) => /lib/ (0x00007f0bdebe9000) => /lib/ (0x00007f0bde9cc000)
/lib64/ (0x00007f0bdf79a000)
p34:~# ldd `which restore` => (0x00007fff857ed000) => /lib/ (0x00007f5b5c3cd000) => /lib/ (0x00007f5b5c1ca000) => /lib/ (0x00007f5b5bfc3000) => /lib/ (0x00007f5b5bd83000) => /lib/ (0x00007f5b5bb3e000) => /lib/ (0x00007f5b5b7e9000) => /lib/ (0x00007f5b5b5cd000)
/lib64/ (0x00007f5b5c60e000) => /lib/ (0x00007f5b5b3c9000)
p34:~# dpkg -l | grep libext2fs
p34:~# dpkg -l | grep libe2fs
p34:~# dpkg -l | grep e2fs
ii e2fslibs 1.41.10-1 ext2/ext3/ext4 file system libraries
ii e2fsprogs 1.41.10-1 ext2/ext3/ext4 file system utilities

p34:~# dpkg -S /lib/
e2fslibs: /lib/


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at