Re: [RFC 09/15] PM / Hibernate: user, implement user_ops writer

From: Rafael J. Wysocki
Date: Thu Mar 25 2010 - 18:12:05 EST


On Wednesday 24 March 2010, Jiri Slaby wrote:
> On 03/24/2010 09:42 PM, Pavel Machek wrote:
> >> + if (test_bit(TODO_CLOSED, to_do_flags))
> >> + return -EIO;
> >> +
> >> + to_do_buf = buf;
> >> + wmb();
> >> + set_bit(TODO_WORK, to_do_flags);
> >> + wake_up_interruptible(&to_do_wait);
> >
> > Uhuh, open-coded barriers... these need to be commented, and I guess
> > you just should not play this kind of trickery.
>
> It's just to ensure the to_do_buf store is not reordered with the
> set_bit. I wanted to avoid locks as too heavy tools here.

No, please use them, at least in a prototype version.

We can always optimize things out later, but doing optimizations upfront
doesn't really work well from my experience.

So, if you'd use a lock somewhere, please use it, or maybe use a completion if
that fits the design better. In the majority of cases it's not as heavy wieght
as it seems at first sight.

Rafael
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/