Re: set_cpus_allowed_ptr

From: Peter Zijlstra
Date: Fri Mar 26 2010 - 07:52:47 EST


On Fri, 2010-03-26 at 12:22 +0100, Julia Lawall wrote:
> On Fri, 26 Mar 2010, Peter Zijlstra wrote:
>
> > Hi,
> >
> > Would it make sense to clean up the set_cpus_allowed() vs
> > set_cpus_allowed_ptr() mess using the semantic patch tool?
> >
> > I guess it would be three patches:
> > 1) converting the current remaining set_cpus_allowed() users into
> > set_cpus_allowed_ptr().
> > 2) remove set_cpus_allowed().
> > 3) rename set_cpus_allowed_ptr() to set_cpus_allowed()
>
> Perhaps a subtlety is that set_cpus_allowed is creating a new variable,
> whose address it sends to set_cpus_allowed_ptr?

Yes it does that, but I don't think that actually matters,
set_cpus_allowed_ptr()'s arg is const, so making that temporary copy
shouldn't have any side effects.



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/