Re: [PATCH 11/11] Unplug emulated disks and nics

From: Stefano Stabellini
Date: Wed May 26 2010 - 08:23:38 EST


On Tue, 25 May 2010, Jeremy Fitzhardinge wrote:
> Could you give this a bit more of a descriptive name, type and/or
> comment? What is it indicating about the xen_platform_pci driver? That
> it has been detected? That it is in use? That it can be used? Is it
> boolean, or can it have any value?
>
>

It is boolean and it signals that the xen platform pci device can be
used. I'll add a comment and rename it to xen_platform_pci_enabled.


> > + */
> > +
> > +#ifndef _XEN_PLATFORM_PCI_H
> > +#define _XEN_PLATFORM_PCI_H
> > +
> > +#include <linux/version.h>
> >
> Why?
>

It is needed for LINUX_VERSION_CODE, see below:

> > +
> > +#define XEN_IOPORT_MAGIC_VAL 0x49d2
> > +#define XEN_IOPORT_LINUX_PRODNUM 0xffff
> > +#define XEN_IOPORT_LINUX_DRVVER ((LINUX_VERSION_CODE << 8) + 0x0)
> > +
> > +extern int xen_platform_pci;
> >
>
> I still think these headers should be folded together. There's no point
> in having them separate. They describe an ABI, so there's no need to
> keep the files in sync with the master Xen sources (since the ABI will
> never change).

All right, I also agree with the other comments.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/