Re: [PATCHv4 01/17] VFS: introduce helpers for the s_dirty flag

From: Andrew Morton
Date: Fri May 28 2010 - 16:24:16 EST


On Tue, 25 May 2010 16:48:56 +0300
Artem Bityutskiy <dedekind1@xxxxxxxxx> wrote:

> From: Artem Bityutskiy <Artem.Bityutskiy@xxxxxxxxx>
>
> This patch introduces 3 new VFS helpers: 'mark_sb_dirty()',
> 'mark_sb_clean()', and 'is_sb_dirty()'. The helpers simply
> set 'sb->s_dirt' or test 'sb->s_dirt'. The plan is to make
> every FS use these helpers instead of manipulating the
> 'sb->s_dirt' flag directly.
>
> Ultimately, this change is a preparation for the periodic
> superblock synchronization optimization which is about
> preventing the "sync_supers" kernel thread from waking up
> even if there is nothing to synchronize.
>
> This patch also makes VFS use the new helpers.

Patchset generally looks good to me. But I don't like the names :(

> +static inline void mark_sb_dirty(struct super_block *sb)
> +{
> + sb->s_dirt = 1;
> +}
> +static inline void mark_sb_clean(struct super_block *sb)
> +{
> + sb->s_dirt = 0;
> +}
> +static inline int is_sb_dirty(struct super_block *sb)
> +{
> + return sb->s_dirt;
> +}

A more conventional and superior naming scheme is
subsystemid_specific_function_identifier(). eg, bio_add_page() instead
of add_page_to_bio().

So these want to be sb_mark_dirty(), etc.

Being very old code written by very yound people, the VFS kinda ignores
that convention, but it doesn't hurt to use it for new code.

Feel free to ignore me if that's too much of a PITA ;)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/