Re: [PATCHv4 01/17] VFS: introduce helpers for the s_dirty flag

From: Artem Bityutskiy
Date: Sat May 29 2010 - 03:59:43 EST


On Fri, 2010-05-28 at 13:23 -0700, Andrew Morton wrote:
> > +static inline void mark_sb_dirty(struct super_block *sb)
> > +{
> > + sb->s_dirt = 1;
> > +}
> > +static inline void mark_sb_clean(struct super_block *sb)
> > +{
> > + sb->s_dirt = 0;
> > +}
> > +static inline int is_sb_dirty(struct super_block *sb)
> > +{
> > + return sb->s_dirt;
> > +}
>
> A more conventional and superior naming scheme is
> subsystemid_specific_function_identifier(). eg, bio_add_page() instead
> of add_page_to_bio().
>
> So these want to be sb_mark_dirty(), etc.
>
> Being very old code written by very yound people, the VFS kinda ignores
> that convention, but it doesn't hurt to use it for new code.
>
> Feel free to ignore me if that's too much of a PITA ;)

Sure I'll re-name them, thanks!

--
Best Regards,
Artem Bityutskiy (ÐÑÑÑÐ ÐÐÑÑÑÐÐÐ)

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/