Re: [PATCH 03/28] rename anon_vma_lock to vma_lock_anon_vma

From: Peter Zijlstra
Date: Mon Jun 07 2010 - 11:02:06 EST


On Mon, 2010-06-07 at 13:06 +0200, Peter Zijlstra wrote:

> From: Rik van Riel <riel@xxxxxxxxxx>
>
> Rename anon_vma_lock to vma_lock_anon_vma. This matches the
> naming style used in page_lock_anon_vma and will come in really
> handy further down in this patch series.
>
> Signed-off-by: Rik van Riel <riel@xxxxxxxxxx>
> Acked-by: Mel Gorman <mel@xxxxxxxxx>
> Acked-by: KAMEZAWA Hiroyuki <kamezawa.hiroyu@xxxxxxxxxxxxxx>
> Signed-off-by: Peter Zijlstra <a.p.zijlstra@xxxxxxxxx>
> LKML-Reference: <20100526153853.55b72183@xxxxxxxxxxxxxxxxxxxxx>
> ---

Missed a refresh... the below bit also wants in.

---
Index: linux-2.6/mm/mmap.c
===================================================================
--- linux-2.6.orig/mm/mmap.c
+++ linux-2.6/mm/mmap.c
@@ -1783,7 +1783,7 @@ static int expand_downwards(struct vm_ar
vma->vm_pgoff -= grow;
}
}
- anon_vma_unlock(vma);
+ vma_unlock_anon_vma(vma);
return error;
}



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/