Re: [PATCH 5/9] oom: cleanup has_intersects_mems_allowed()

From: KOSAKI Motohiro
Date: Wed Jun 30 2010 - 05:26:42 EST

> On Mon, 21 Jun 2010, KOSAKI Motohiro wrote:
> > > I disagree that the renaming of the variables is necessary, please simply
> > > change the while (tsk != start) to use while_each_thread(tsk, start);
> >
> > This is common naming rule of while_each_thread(). please grep.
> >
> I disagree, there's no sense in substituting variable names like "tsk" for
> `p' and removing a very clear and obvious "start" task: it doesn't improve
> code readability.
> I'm in favor of changing the while (tsk != start) to
> while_each_thread(tsk, start) which is very trivial to understand and much
> more readable than while_each_thread(p, tsk). With the latter, it's not
> clear whether `p' or "tsk" is the iterator and which is the constant.

Heh, I'm ok this. It isn't big matter at all.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at