Re: [PATCH] ARM/nuc900: fix nuc900 touchscreen clk definition bug

From: Wan ZongShun
Date: Fri Jul 16 2010 - 05:11:48 EST


2010/7/16 Marek Vasut <marek.vasut@xxxxxxxxx>:
> Dne PÃ 16. Äervence 2010 07:34:21 Wan ZongShun napsal(a):
>> 2010/7/16 Marek Vasut <marek.vasut@xxxxxxxxx>:
>> > Dne PÃ 16. Äervence 2010 05:03:27 Wan ZongShun napsal(a):
>> >> This patch is to fix nuc900 touchscreen clk definition bug,the .dev_id's
>> >> name should be 'nuc900-ts', it should be the same to pdev.name. or else,
>> >> the touchscreen driver will be not working well due to clock engine
>> >> disabled.
>> >>
>> >> Signed-off-by: Wan ZongShun <mcuos.com@xxxxxxxxx>
>> >> ---
>> >> Âarch/arm/mach-w90x900/cpu.c | Â Â2 +-
>> >> Â1 files changed, 1 insertions(+), 1 deletions(-)
>> >>
>> >> diff --git a/arch/arm/mach-w90x900/cpu.c b/arch/arm/mach-w90x900/cpu.c
>> >> index 642207e..83c5632 100644
>> >> --- a/arch/arm/mach-w90x900/cpu.c
>> >> +++ b/arch/arm/mach-w90x900/cpu.c
>> >> @@ -93,7 +93,7 @@ static struct clk_lookup nuc900_clkregs[] = {
>> >> Â Â Â DEF_CLKLOOK(&clk_kpi, "nuc900-kpi", NULL),
>> >> Â Â Â DEF_CLKLOOK(&clk_wdt, "nuc900-wdt", NULL),
>> >> Â Â Â DEF_CLKLOOK(&clk_gdma, "nuc900-gdma", NULL),
>> >> - Â Â DEF_CLKLOOK(&clk_adc, "nuc900-adc", NULL),
>> >> + Â Â DEF_CLKLOOK(&clk_adc, "nuc900-ts", NULL),
>> >> Â Â Â DEF_CLKLOOK(&clk_usi, "nuc900-spi", NULL),
>> >> Â Â Â DEF_CLKLOOK(&clk_ext, NULL, "ext"),
>> >> Â Â Â DEF_CLKLOOK(&clk_timer0, NULL, "timer0"),
>> >
>> > Hey,
>> >
>> > Is that thing really touchscreen or general-purpose analog/digital
>> > converter ?
>>
>> Oh, it is general-purpose analog/digital converter controller.
>> I only use it to implemnt my touchscreen function, Also it can be use
>> other function.
>>
>> so, I have to change my touchscreen driver name to nuc900-adc?
>
> No, just change the name of clock in the touchscreen driver. So that the
> touchscreen driver will use nuc900-adc clocksource.


But the clk_get() identifies this clk via looking driver or pdev name.
so I must change my touchscreen driver name, right?
>
> You're welcome. :)
>
>>
>> Thanks for your Reminder, I appreciate it. :)
>>
>> > Cheers
>



--
*linux-arm-kernel mailing list
mail addr:linux-arm-kernel@xxxxxxxxxxxxxxxxxxx
you can subscribe by:
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

* linux-arm-NUC900 mailing list
mail addr:NUC900@xxxxxxxxxxxxxxxx
main web: https://groups.google.com/group/NUC900
you can subscribe it by sending me mail:
mcuos.com@xxxxxxxxx
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/