[PATCH] ds2782_battery: Rename get_current and get_voltageoperations

From: Ben Hutchings
Date: Mon Jul 19 2010 - 20:03:38 EST


commit 9b9ade6b612e562c4a5bd02ef38cc32e10f3f9ba "ds2782_battery: Add
support for ds2786 battery gas gauge" introduced an operation named
get_current. Since get_current() is defined as a macro on some
architectures this driver no longer compiles on those architectures.

Rename get_current to get_current_now to avoid the macro.
Rename get_voltage to get_voltage_now for consistency.

Reported-by: Geert Stappers <stappers@xxxxxxxxxxx>
Signed-off-by: Ben Hutchings <ben@xxxxxxxxxxxxxxx>
---
drivers/power/ds2782_battery.c | 22 +++++++++++-----------
1 files changed, 11 insertions(+), 11 deletions(-)

diff --git a/drivers/power/ds2782_battery.c b/drivers/power/ds2782_battery.c
index d762a0c..8d0673f 100644
--- a/drivers/power/ds2782_battery.c
+++ b/drivers/power/ds2782_battery.c
@@ -43,8 +43,8 @@
struct ds278x_info;

struct ds278x_battery_ops {
- int (*get_current)(struct ds278x_info *info, int *current_uA);
- int (*get_voltage)(struct ds278x_info *info, int *voltage_uA);
+ int (*get_current_now)(struct ds278x_info *info, int *current_uA);
+ int (*get_voltage_now)(struct ds278x_info *info, int *voltage_uA);
int (*get_capacity)(struct ds278x_info *info, int *capacity_uA);

};
@@ -213,7 +213,7 @@ static int ds278x_get_status(struct ds278x_info *info, int *status)
int current_uA;
int capacity;

- err = info->ops->get_current(info, &current_uA);
+ err = info->ops->get_current_now(info, &current_uA);
if (err)
return err;

@@ -250,11 +250,11 @@ static int ds278x_battery_get_property(struct power_supply *psy,
break;

case POWER_SUPPLY_PROP_VOLTAGE_NOW:
- ret = info->ops->get_voltage(info, &val->intval);
+ ret = info->ops->get_voltage_now(info, &val->intval);
break;

case POWER_SUPPLY_PROP_CURRENT_NOW:
- ret = info->ops->get_current(info, &val->intval);
+ ret = info->ops->get_current_now(info, &val->intval);
break;

case POWER_SUPPLY_PROP_TEMP:
@@ -307,14 +307,14 @@ enum ds278x_num_id {

static struct ds278x_battery_ops ds278x_ops[] = {
[DS2782] = {
- .get_current = ds2782_get_current,
- .get_voltage = ds2782_get_voltage,
- .get_capacity = ds2782_get_capacity,
+ .get_current_now = ds2782_get_current,
+ .get_voltage_now = ds2782_get_voltage,
+ .get_capacity = ds2782_get_capacity,
},
[DS2786] = {
- .get_current = ds2786_get_current,
- .get_voltage = ds2786_get_voltage,
- .get_capacity = ds2786_get_capacity,
+ .get_current_now = ds2786_get_current,
+ .get_voltage_now = ds2786_get_voltage,
+ .get_capacity = ds2786_get_capacity,
}
};

--
1.7.1


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/