Re: [PATCH net-next] drivers/net/bfin_mac.c: Use pr_fmt,netdev_<level>

From: Joe Perches
Date: Tue Jul 27 2010 - 16:52:44 EST


On Tue, 2010-07-27 at 13:44 -0700, Stephen Hemminger wrote:
> On Tue, 27 Jul 2010 12:22:11 -0700
> Joe Perches <joe@xxxxxxxxxxx> wrote:
> > +static struct sk_buff *bfin_alloc_skb(void)
> > +{
> > + /* allocate a new skb */
> > + struct sk_buff *new_skb = dev_alloc_skb(PKT_BUF_SIZE + NET_IP_ALIGN);
> > +
> > + if (!new_skb)
> > + return NULL;
> > +
> > + skb_reserve(new_skb, NET_IP_ALIGN);
>
> Why not use netdev_alloc_skb_ip_align ?

I was consolidating duplicated code.

It could be changed, but right now, desc_list_init isn't
passed a struct netdevice.

Perhaps you'll submit that as a follow-on?


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/