Re: [PATCH 1/2] x86, setup: reorgize the early_console_setup

From: H. Peter Anvin
Date: Mon Aug 02 2010 - 14:28:24 EST


On 08/02/2010 10:56 AM, Thiago Farina wrote:
>
> These to functions above can be fairly simplified by writting as:
>
> static bool inline is_hex_digit(int c) {
> return (c >= '0' && c <= '9') ||
> (c >= 'A' && c <= 'F') ||
> (c >= 'a' && c <= 'f');
> }
>

a) You lose the isdigit() functionality, which is useful on its own.
b) Does this enahance readability in any way?
c) Your proposed renaming is nonstandard.

As such, I don't think this is a good idea.

-hpa
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/