Re: kernel BUG at fs/ext4/mballoc.c:2993!

From: Ted Ts'o
Date: Sat Aug 07 2010 - 02:45:26 EST

On Fri, Aug 06, 2010 at 10:48:40PM -0700, Justin Mattock wrote:
> hello,
> I just built a fresh clfs system using the tutorial.. right now Im
> able to boot and am able to login, the system seems to be running as
> it should except for when I try to install gmp and/or do a /sbin/lilo
> I see a message appear on screen(below) then if I do any kind of
> command(dmesg > dmesg) I get a stuck screen. has there been anything
> similar to the below message?
> keep in mind the kernel I'm using is 2.6.35-rc6 which on other
> machines(same type of system) run just fine without such message.

Um, is this a completely modified 2.6.35-rc6 kernel? The reason why I
ask is there is no BUG_ON at line fs/ext4/mballoc.c:2993 for that
kernel version.

There are two BUG_ON statements nearby, but given the line number
doesn't match up with either one, it's hard to say for sure which one
triggered it. What were the kernel messages right before the BUG_ON?
was there a "start NNNNN size NNN, fe_logical NNNN" (where NNNN is
some number) right before the "cut here" message?

Have you tried forcing an fsck run on the file system to make sure
it's not caused by a file-system corruption?

And have you tried using a standard released gcc so we can determine
for sure whether this is a potential kernel bug, file system
corruption issue, or gcc issue?

- Ted
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at