Re: [PATCH 6/9] RapidIO: Add switch-specific sysfs initializationcallback

From: Micha Nelissen
Date: Mon Aug 16 2010 - 08:25:58 EST


Alexandre Bounine wrote:
- if (!rdev->rswitch)
- goto out;
-

Is it safe? All devices have a switch?

@@ -63,10 +59,11 @@ struct device_attribute rio_dev_attrs[] = {
__ATTR_RO(asm_did),
__ATTR_RO(asm_vid),
__ATTR_RO(asm_rev),
- __ATTR_RO(routes),
__ATTR_NULL,
};
+static DEVICE_ATTR(routes, S_IRUGO, routes_show, NULL);
+

This seems a separate change from the sw_sysfs? Why make it separate?

*/
struct rio_switch {
@@ -256,6 +257,7 @@ struct rio_switch {
u8 *sw_domain);
int (*em_init) (struct rio_dev *dev);
int (*em_handle) (struct rio_dev *dev, u8 swport);
+ int (*sw_sysfs) (struct rio_dev *dev, int create);
struct rio_dev *nextdev[0];
};

Why not make a sw_sysfs_create and sw_sysfs_remove? Is better for readability. Now you call 'sw_sysfs(dev, 0)' or 'sw_sysfs(dev, 1)';

Micha
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/